Summer Certification Sale 70% Discount Offer - Ends in 0d 00h 00m 00s - Coupon code: save70

Free and Premium Splunk SPLK-1002 Dumps Questions Answers

Page: 1 / 23
Total 313 questions

Splunk Core Certified Power User Exam Questions and Answers

Question 1

The transaction command allows you to __________ events across multiple sources

Options:

A.

duplicate

B.

correlate

C.

persist

D.

tag

Buy Now
Question 2

Which of the following is true about the Splunk Common Information Model (CIM)?

Options:

A.

The data models included in the CIM are configured with data model acceleration turned off.

B.

The CIM contains 28 pre-configured datasets.

C.

The CIM is an app that needs to run on the indexer.

D.

The data models included in the CIM are configured with data model acceleration turned on.

Question 3

Marty has multiple data sources that contain fields with IP Address values. What knowledge object should he use to normalize the fields so his data is CIM compliant?

Options:

A.

Event type

B.

Field alias

C.

Field extraction

D.

Tag

Question 4

Which of the following fields should be normalized using the Splunk Common Information Model (CIM) based on their relationship?

Options:

A.

src_ip, dest_ip

B.

src_ip, source_ip

C.

index, sourcetype

D.

src_ip, src_port

Question 5

Which of the following expressions could be used to create a calculated field called gigabytes?

Options:

A.

eval sc_bytes(1024/1024)

B.

| eval negabytes=sc_bytes(1024/1024)

C.

megabytes=sc_bytes(1024/1024)

D.

sc_bytas(1024/1024)

Question 6

This function of the stats command allows you to return the middle-most value of field X.

Options:

A.

Median(X)

B.

Eval by X

C.

Fields(X)

D.

Values(X)

Question 7

A space is an implied _____ in a search string.

Options:

A.

OR

B.

AND

C.

()

D.

NOT

Question 8

Complete the search, …. | _____ failure > successes

Options:

A.

Search

B.

Where

C.

If

D.

Any of the above

Question 9

When performing a regular expression (regex) field extraction using the Field Extractor (FX), what happens when the require option is used?

Options:

A.

The regex can no longer be edited.

B.

The field being extracted will be required for all future events.

C.

The events without the required field will not display in searches.

D.

Only events with the required string will be included in the extraction.

Question 10

What is a benefit of installing the Splunk Common Information Model (CIM) add-on?

Options:

A.

It permits users to create workflow actions to align with industry standards.

B.

It provides users with a standardized set of field names and tags to normalize data.

C.

It allows users to create 3-D models of their data and export these visualizations.

D.

It enables users to itemize their events based on the results of the Search Job Inspector.

Question 11

Which of the following is one of the pre-configured data models included in the Splunk Common Information Model (CIM) add-on?

Options:

A.

Access

B.

Accounting

C.

Authorization

D.

Authentication

Question 12

Which of the following statements would help a user choose between the transaction and stats commands?

Options:

A.

state can only group events using IP addresses.

B.

The transaction command is faster and more efficient.

C.

There is a 1000 event limitation with the transaction command.

D.

Use state when the events need to be viewed as a single event.

Question 13

When using the Field Extractor (FX), which of the following delimiters will work? (select all that apply)

Options:

A.

Tabs

B.

Pipes

C.

Colons

D.

Spaces

Question 14

How are arguments defined within the macro search string?

Options:

A.

Şarg$

B.

'arg'

C.

%arg%

D.

"arg"

Question 15

Which command can include both an over and a by clause to divide results into sub-groupings?

Options:

A.

chart

B.

stats

C.

xyseries

D.

transaction

Question 16

Which of the following statements best describes a macro?

Options:

A.

A macro is a method of categorizing events based on a search.

B.

A macro is a way to associate an additional (new) name with an existing field name.

C.

A macro is a portion of a search that can be reused in multiple place

D.

A macro is a knowledge object that enables you to schedule searches for specific events.

Question 17

Which of the following definitions describes a macro named "samplemacro" that accepts two arguments?

Options:

A.

Examplemacro [1,2]

B.

samplemacro(1,2)

C.

u amp -CJEUCXG (2)

D.

samplemacro[2]

Question 18

When extracting fields, we may choose to use our own regular expressions

Options:

A.

True

B.

False

Question 19

What is required for a macro to accept three arguments?

Options:

A.

The macro's name ends with (3).

B.

The macro's name starts with (3).

C.

The macro's argument count setting is 3 or more.

D.

Nothing, all macros can accept any number of arguments.

Question 20

What happens to the original field name when a field alias is created?

Options:

A.

The original field name is not affected by the creation of a field alias.

B.

The original field name is replaced by the field alias within the index.

C.

The original field name is italicized to indicate that it is not an alias.

D.

The original field name still exists in the index but is not visible to the user at search time.

Question 21

When using | timechart by host, which field is represented in the x-axis?

Options:

A.

date

B.

host

C.

time

D.

_time

Question 22

What is a limitation of searches generated by workflow actions?

Options:

A.

Searches generated by workflow action cannot use macros.

B.

Searches generated by workflow actions must be less than 256 characters long.

C.

Searches generated by workflow action must run in the same app as the workflow action.

D.

Searches generated by workflow action run with the same permissions as the user running them.

Question 23

Where are the results of eval commands stored?

Options:

A.

In a field.

B.

In an index.

C.

In a KV Store.

D.

In a database.

Question 24

What does the fillnull command do in this search?

index=main sourcetype=http:log | fillnull value="Unknown"

Options:

A.

Set the values of the field to null when it is "Unknown".

B.

Set all fields that are null to "Unknown".

C.

Set the values of the field to "Unknown" if it is null.

D.

Set all fields with the value of "Unknown" to null.

Question 25

Which type of workflow action sends field values to an external resource (e.g. a ticketing system)?

Options:

A.

POST

B.

Search

C.

GET

D.

Format

Question 26

In which of the following scenarios is an event type more effective than a saved search?

Options:

A.

When a search should always include the same time range.

B.

When a search needs to be added to other users' dashboards.

C.

When the search string needs to be used in future searches.

D.

When formatting needs to be included with the search string.

Question 27

How is a Search Workflow Action configured to run at the same time range as the original search?

Options:

A.

Select the "Overwrite time range with the original search" checkbox.

B.

Select the "Use the same time range as the search that created the field listing" checkbox.

C.

Set the earliest time to match the original search.

D.

Select the same time range from the time-range picker.

Question 28

Selected fields are displayed ______each event in the search results.

Options:

A.

below

B.

interesting fields

C.

other fields

D.

above

Question 29

Which of the following searches will show the number of categoryld used by each host?

Options:

A.

Sourcetype=access_* |sum bytes by host

B.

Sourcetype=access_* |stats sum(categorylD. by host

C.

Sourcetype=access_* |sum(bytes) by host

D.

Sourcetype=access_* |stats sum by host

Question 30

Which of the following search modes automatically returns all extracted fields in the fields sidebar?

Options:

A.

Fast

B.

Smart 

C.

C. Verbose

Question 31

There are several ways to access the field extractor. Which option automatically identifies data type, source type, and sample event?

Options:

A.

Event Actions > Extract Fields

B.

Fields sidebar > Extract New Field

C.

Settings > Field Extractions > New Field Extraction

D.

Settings > Field Extractions > Open Field Extraction

Question 32

Which of the following statements describes POST workflow actions?

Options:

A.

POST workflow actions are always encrypted.

B.

POST workflow actions cannot use field values in their URI.

C.

POST workflow actions cannot be created on custom sourcetypes.

D.

POST workflow actions can open a web page in either the same window or a new .

Question 33

How could the following syntax for the chart command be rewritten to remove the OTHER category? (select all that apply)

Options:

A.

| chart count over CurrentStanding by Action useother=f

B.

| chart count over CurrentStanding by Action usenull-f useother-t

C.

| chart count over CurrentStanding by Action limit=10 useother=f

D.

| chart count over CurrentStanding by Action limit-10

Question 34

Which of the following searches will return events containing a tag named Privileged?

Options:

A.

tag=Priv

B.

tag=Priv*

C.

tag=priv*

D.

tag=privileged

Question 35

For the following search, which command would further filter for only IP addresses present more than five times?

Options:

A.

index=games I stats count as IP_count by IP B. | where IP_count > 5

B.

index=games | search IP_Count > 5

C.

index=games | where IP > 5

D.

index=games I search IP > 5

Question 36

This function of the stats command allows you to return the sample standard deviation of a field.

Options:

A.

stdev

B.

dev

C.

count deviation

D.

by standarddev

Question 37

Using the export function, you can export search results as __________.( Select all that apply)

Options:

A.

Xml

B.

Json

C.

Html

D.

A php file

Question 38

These allow you to categorize events based on search terms.

Select your answer.

Options:

A.

Groups

B.

Event Types

C.

Macros

D.

Tags

Question 39

In what order arc the following knowledge objects/configurations applied?

Options:

A.

Field Aliases, Field Extractions, Lookups

B.

Field Extractions, Field Aliases, Lookups

C.

Field Extractions, Lookups, Field Aliases

D.

Lookups, Field Aliases, Field Extractions

Question 40

What is the correct syntax to search for a tag associated with a value on a specific fields?

Options:

A.

Tag- < field?

B.

Tag < filed(tagname.)

C.

Tag= < filed > :: < tagname >

D.

Tag:: < filed > = < tagname >

Question 41

Which of the following statements best describes the search string below?

| datamodel Application_State search

Options:

A.

Events will be returned from dataset Application_State.

B.

Events will be returned from the data model named Application_State.

C.

No events will be returned; the pipe must occur after the data model command.

D.

Events will be returned from the data model named Application_State (flat mode).

Question 42

When is a GET workflow action needed?

Options:

A.

To send field values to an external resource.

B.

To retrieve information from an external resource.

C.

To use field values to perform a secondary search.

D.

To define how events flow from forwarders to indexes.

Question 43

When using the transaction command, what does the argument maxspan do?

Options:

A.

Sets the maximum total time between events in a transaction.

B.

Sets the maximum length of all events within a transaction.

C.

Sets the maximum total time between the earliest and latest events in a transaction.

D.

Sets the maximum length that any single event can reach to be included in the transaction.

Question 44

Which of the following searches show a valid use of a macro? (Choose all that apply.)

Options:

A.

index=main source=mySource oldField=* |’makeMyField(oldField)’| table _time newField

B.

index=main source=mySource oldField=* | stats if(‘makeMyField(oldField)’) | table _time newField

C.

index=main source=mySource oldField=* | eval newField=’makeMyField(oldField)’| table _time newField

D.

index=main source=mySource oldField=* | "’newField(‘makeMyField(oldField)’)’" | table _time newField

Question 45

Which workflow uses field values to perform a secondary search?

Options:

A.

POST

B.

Action

C.

Search

D.

Sub-Search

Question 46

What syntax would a user specify to search for the prod tag associated with the host field and webserver value?

Options:

A.

prod:host=webserver

B.

tag::host=prod

C.

prod=host:webserver

D.

prod=host::webserver

Question 47

By default search results are not returned in ________ order.

Options:

A.

Chronological

B.

Reverser chronological

C.

ASCIE

D.

Alphabetical

Question 48

Which of the following commands will show the maximum bytes?

Options:

A.

sourcetype=access_* | maximum totals by bytes

B.

sourcetype=access_* | avg (bytes)

C.

sourcetype=access_* | stats max(bytes)

D.

sourcetype=access_* | max(bytes)

Question 49

Which of these is NOT a field that is automatically created with the transaction command?

Options:

A.

maxcount

B.

duration

C.

eventcount

Question 50

Which of the following options will define the first event in a transaction?

Options:

A.

startswith

B.

with

C.

startingwith

D.

firstevent

Question 51

Which of the following statements describe calculated fields? (select all that apply)

Options:

A.

Calculated fields can be used in the search bar.

B.

Calculated fields can be based on an extracted field.

C.

Calculated fields can only be applied to host and sourcetype.

D.

Calculated fields are shortcuts for performing calculations using the eval command.

Question 52

Splunk alerts can be based on search that run______. (Select all that apply.)

Options:

A.

in real-time

B.

on a regular schedule

C.

and have no matching events

Question 53

Which of the following statements describe the search string below?

| datamodel Application_State All_Application_State search

Options:

A.

Evenrches would return a report of sales by state.

B.

Events will be returned from the data model named Application_State.

C.

Events will be returned from the data model named All_Application_state.

D.

No events will be returned because the pipe should occur after the datamodel command

Question 54

What other syntax will produce exactly the same results as | chart count over vendor_action by user?

Options:

A.

| chart count by vendor_action, user

B.

| chart count over vendor_action, user

C.

| chart count by vendor_action over user

D.

| chart count over user by vendor_action

Question 55

When should the delimiter method be used in the Field Extractor?

Options:

A.

When the events do not have the correct permissions set.

B.

When the events are separated by a consistent character or set of characters.

C.

When the events need a regular expression to define the matching pattern.

D.

When the events need to be calculated using special characters.

Question 56

Which of the following knowledge objects represents the output of an eval expression?

Options:

A.

Eval fields

B.

Calculated fields

C.

Field extractions

D.

Calculated lookups

Question 57

What is the Splunk Common Information Model (CIM)?

Options:

A.

The CIM is a prerequisite that any data source must meet to be successfully onboarded into Splunk.

B.

The CIM provides a methodology to normalize data from different sources and source types.

C.

The CIM defines an ecosystem of apps that can be fully supported by Splunk.

D.

The CIM is a data exchange initiative between software vendors.

Question 58

A user wants to retrieve IP address information. How should the URI be specified to configure a GET workflow action?

Options:

A.

http://whois.net/whois/'domain'

B.

http://whois.net/whois/$domain$

C.

http://whois.net/whois/%domain%

D.

http://whois.net/whois/*domain*

Question 59

Which of the following is a feature of the Pivot tool?

Options:

A.

Creates lookups without using SPL.

B.

Data Models are not required.

C.

Creates reports without using SPL

D.

Datasets are not required.

Question 60

When creating an event type, which is allowed in the search string?

Options:

A.

Tags

B.

Joins

C.

Subsearches

D.

Pipes

Question 61

Clicking a SEGMENT on a chart, ________.

Options:

A.

drills down for that value

B.

highlights the field value across the chart

C.

adds the highlighted value to the search criteria

Question 62

What is needed to define a calculated field?

Options:

A.

Eval expression

B.

Data model

C.

Event type

D.

Regular expression

Question 63

Which of the following statements about tags is true?

Options:

A.

Tags are case insensitive.

B.

Tags are created at index time.

C.

Tags can make your data more understandable.

D.

Tags are searched by using the syntax tag: : < fieldneme >

Question 64

The timechart command buckets data in time intervals depending on:

Options:

A.

the number of events returned

B.

the selected time range

C.

the type of visualization selected

Question 65

The limit attribute will___________.

Options:

A.

override default of 10

B.

only work with top command

C.

override default of 20

D.

override default of 15

Question 66

Which of the following are valid options to speed up reports? (Select all the apply.)

Options:

A.

Edit permissions

B.

Edit description

C.

Edit acceleration

D.

Edit schedule

Question 67

For the following search, which field populates the x-axis?

index=security sourcetype=linux secure | timechart count by action

Options:

A.

action

B.

source type

C.

_time

D.

time

Question 68

This is what Splunk uses to categorize the data that is being indexed.

Options:

A.

Host

B.

Sourcetype

C.

Index

D.

Source

Question 69

How are event types different from saved reports?

Options:

A.

Event types cannot be used to organize data into categories.

B.

Event types include formatting of the search results.

C.

Event types can be shared with Splunk users and added to dashboards.

D.

Event types do not include a time range.

Question 70

In the Field Extractor Utility, this button will display events that do not contain extracted fields.

Select your answer.

Options:

A.

Selected-Fields

B.

Non-Matches

C.

Non-Extractions

D.

Matches

Question 71

Which of the following statements describes POST workflow actions?

Options:

A.

Configuration of a POST workflow action includes choosing a sourcetype.

B.

POST workflow actions can be configured to send email to the URI location.

C.

By default, POST workflow action are shown in both the event and field menus.

D.

POST workflow actions can be configured to send POST arguments to the URI location.

Question 72

Which of these stats commands will show the total bytes for each unique combination of page and server?

Options:

A.

index=web | stats sum (bytes) BY page BY server

B.

index=web | stats sum (bytes) BY page server

C.

index=web | stats sum(bytes) BY page AND server

D.

index=web | stats sum(bytes) BY values (page) values (server)

Question 73

This function of the stats command allows you to identify the number of values a field has.

Options:

A.

max

B.

distinct_count

C.

fields

D.

count

Question 74

Which of the following can be saved as an event type?

Options:

A.

index=server_48 sourcetype=BETA_881 code=220

B.

index=server_48 sourcetype=BETA_881 code=220 | stats count by code

C.

index=server_48 sourcetype=BETA_881 code=220 | inputlookup append=t servercode.csv

D.

index=server_48 sourcetype=BETA_881 code=220 | stats where code > 220

Question 75

Which of the following is true about Pivot?

Options:

A.

Users can save reports from Pivot.

B.

Users cannot share visualizations created with Pivot.

C.

Users must use SPL to find events in a Pivot.

D.

Users cannot create visualizations with Pivot.

Question 76

What type of command is eval?

Options:

A.

Streaming in some modes

B.

Report generating

C.

Distributable streaming

D.

Centralized streaming

Question 77

Which statement is true?

Options:

A.

Pivot is used for creating datasets.

B.

Data models are randomly structured datasets.

C.

Pivot is used for creating reports and dashboards.

D.

In most cases, each Splunk user will create their own data model.

Question 78

Which of the following searches would create a graph similar to the one below?

Options:

A.

index_internal seourcetype=Savesplunker | fields sourcetype, status | transaction status maxspan-id | start count states

B.

index_internal seourcetype=Savesplunker | fields sourcetype, status | transaction status maxspan-id | chart count states by -time

C.

index_internal seourcetype=Savesplunker | fields sourcetype, status | transaction status maxspan-id | timechart count by status

D.

None of these searches would generate a similart graph.

Question 79

How many ways are there to access the Field Extractor Utility?

Options:

A.

3

B.

4

C.

1

D.

5

Question 80

If a search returns ____________ it can be viewed as a chart.

Options:

A.

timestamps

B.

statistics

C.

events

D.

keywords

Question 81

Given the following eval statement:

...| eval fieldl - if(isnotnull(fieldl),fieldl,0), field2 = if(isnull < field2 > , "NO-VALUE", fieid2)

Which of the following is the equivalent using f ilinull?

Options:

A.

There is no equivalent expression using f ilinull

B.

... t filinull values=(0,"NO-VALUE") fields=(fieldl,field2)

C.

... I filinull value=0 fieldl I fillnull fields

D.

... I fillnull fieldl I filinull value="NO-VALUE" field2

Question 82

Given the event below, how can the value in the Zip_Code field be used to retrieve the local weather from an external resource?

25/Oct/2023:20:29:43 , 151.131.173.143 , V2.003 , Zip_Code: 75890 , DataCenter: DC1

Options:

A.

Create a POST workflow action.

B.

Create a GET workflow action.

C.

Create a PUT workflow action.

D.

Create a Search workflow action.

Question 83

Which of the following statements about calculated fields in Splunk is true?

Options:

A.

Calculated fields cannot be chained together to create more complex fields

B.

Calculated fields can be chained together to create more complex fields.

C.

Calculated fields can only be used in dashboards.

D.

Calculated fields can only be used in saved reports.

Question 84

These users can create global knowledge objects. (Select all that apply.)

Options:

A.

users

B.

power users

C.

administrators

Question 85

Which of the following is included with the Common Information Model (CIM) add-on?

Options:

A.

Search macros

B.

Event category tags

C.

Workflow actions

D.

tsidx files

Question 86

Which of the following statements describe GET workflow actions?

Options:

A.

GET workflow actions must be configured with POST arguments.

B.

Configuration of GET workflow actions includes choosing a sourcetype.

C.

Label names for GET workflow actions must include a field name surrounded by dollar signs.

D.

GET workflow actions can be configured to open the URT link in the current window or in a new window

Question 87

Which of the following statements describe the search below? (select all that apply)

Index=main I transaction clientip host maxspan=30s maxpause=5s

Options:

A.

Events in the transaction occurred within 5 seconds.

B.

It groups events that share the same clientip and host.

C.

The first and last events are no more than 5 seconds apart.

D.

The first and last events are no more than 30 seconds apart.

Question 88

Field aliases are used to __________ data

Options:

A.

clean

B.

transform

C.

calculate

D.

normalize

Question 89

A user wants to create a workflow action that will retrieve a specific field value from an event and run a search in a new browser window

in the user's Splunk instance. What kind of workflow action should they create?

Options:

A.

A Run workflow action, because the user is running a new search with a specific field value from an event returned in the user's search.

B.

A Search workflow action, because the user is running a new search with a specific field value from an event returned in the user's search.

C.

A POST workflow action, because the search is being sent to the user's current Splunk instance.

D.

A GET workflow action, because a field value needs to be retrieved from the events returned in the user's search.

Question 90

In this search, __________ will appear on the y-axis. SEARCH: sourcetype=access_combined status!=200 | chart count over host

Options:

A.

status

B.

host

C.

count

Question 91

A user runs the following search:

index—X sourcetype=Y I chart count (domain) as count, sum (price) as sum by product, action usenull=f useother—f

Which of the following table headers match the order this command creates?

Options:

A.

The chart command does not allow for multiple statistical functions.

B.

Product, sum: addtocart, sum: remove, sum: purchase, count: addtocart, count: remove, count: purchase

C.

Product, count: addtocart, count: remove, count: purchase, sum: addtocart, sum: remove, sum: purchase

D.

Count: product, sum: product, count: action, sum: action

Question 92

Which of the following statements describes calculated fields?

Options:

A.

Calculated fields are only used on fields added by lookups.

B.

Calculated fields are a shortcut for repetitive and complex eval commands.

C.

Calculated fields are a shortcut for repetitive and complex calc commands.

D.

Calculated fields automatically calculate the simple moving average for indexed fields.

Question 93

These kinds of charts represent a series in a single bar with multiple sections

Options:

A.

Multi-Series

B.

Split-Series

C.

Omit nulls

D.

Stacked

Page: 1 / 23
Total 313 questions